PHP < 5.2.8 Multiple Vulnerabilities

High Nessus Plugin ID 35067

Synopsis

The remote web server uses a version of PHP that may be affected by multiple vulnerabilities.

Description

According to its banner, the version of PHP installed on the remote host is earlier than 5.2.8. As such, it is potentially affected by the following vulnerabilities :

- PHP fails to properly sanitize error messages of arbitrary HTML or script code, would code allow for cross-site scripting attacks if PHP's 'display_errors' setting is enabled. (CVE-2008-5814)

- Version 5.2.7 introduced a regression with regard to 'magic_quotes' functionality due to an incorrect fix to the filter extension. As a result, the 'magic_quotes_gpc' setting remains off even if it is set to on. (CVE-2008-5844)

Solution

Upgrade to PHP version 5.2.8 or later.

See Also

https://bugs.php.net/bug.php?id=42718

http://www.php.net/releases/5_2_8.php

Plugin Details

Severity: High

ID: 35067

File Name: php_5_2_8.nasl

Version: 1.18

Type: remote

Family: CGI abuses

Published: 2008/12/09

Updated: 2018/11/15

Dependencies: 48243

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Available: false

Exploit Ease: No exploit is required

Reference Information

CVE: CVE-2008-5814, CVE-2008-5844

BID: 32673

CWE: 16, 79