PHP < 5.2.8 Multiple Vulnerabilities

high Nessus Plugin ID 35067


The remote web server uses a version of PHP that may be affected by multiple vulnerabilities.


According to its banner, the version of PHP installed on the remote host is earlier than 5.2.8. As such, it is potentially affected by the following vulnerabilities :

- PHP fails to properly sanitize error messages of arbitrary HTML or script code, would code allow for cross-site scripting attacks if PHP's 'display_errors' setting is enabled. (CVE-2008-5814)

- Version 5.2.7 introduced a regression with regard to 'magic_quotes' functionality due to an incorrect fix to the filter extension. As a result, the 'magic_quotes_gpc' setting remains off even if it is set to on. (CVE-2008-5844)


Upgrade to PHP version 5.2.8 or later.

See Also

Plugin Details

Severity: High

ID: 35067

File Name: php_5_2_8.nasl

Version: 1.20

Type: remote

Family: CGI abuses

Published: 12/9/2008

Updated: 4/11/2022

Risk Information


Risk Factor: Medium

Score: 5.5


Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Ease: No exploit is required

Reference Information

CVE: CVE-2008-5814, CVE-2008-5844

BID: 32673

CWE: 16, 79