Apache < 2.2.9 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 4579


The remote web server may be affected by several issues.


According to its banner, the version of Apache 2.2 installed on the remote host is older than 2.2.9. Such versions may be affected by several issues, including :

- Improper handling of excessive forwarded interim responses may cause denial of service conditions in mod_proxy_http (CVE-2008-2364).
- A cross-site request forgery vulnerability in the balancer-manager interface of mod_proxy_balancer (CVE-2007-6420).
- An issue exists in the handling of the 'Options' and 'AllowOverride' directives (CVE-2009-1195).

Note that the remote web server may not actually be affected by these vulnerabilities. NNM cannot determine whether the affected modules are in use.


Either ensure that the affected modules are not in use or upgrade to Apache version 2.2.9 or higher.

See Also




Plugin Details

Severity: High

ID: 4579

Family: Web Servers

Published: 2004/08/18

Updated: 2019/03/06

Dependencies: 3057

Nessus ID: 33477

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server:2.0

Reference Information

CVE: CVE-2007-6420, CVE-2007-6421, CVE-2007-6422, CVE-2007-6423, CVE-2008-2364, CVE-2009-1195

BID: 35115, 27236, 29653