Apache 2.2.x < 2.2.9 Multiple Vulnerabilities (DoS, XSS)

Medium Nessus Plugin ID 33477


The remote web server may be affected by several issues.


According to its banner, the version of Apache 2.2.x running on the remote host is prior to 2.2.9. It is, therefore, affected by multiple vulnerabilities :

- Improper handling of excessive forwarded interim responses may cause denial of service conditions in mod_proxy_http. (CVE-2008-2364)

- A cross-site request forgery vulnerability in the balancer-manager interface of mod_proxy_balancer.

Note that the remote web server may not actually be affected by these vulnerabilities. Nessus did not try to determine whether the affected modules are in use or to check for the issues themselves.


Upgrade to Apache version 2.2.9 or later. Alternatively, ensure that the affected modules are not in use.

See Also



Plugin Details

Severity: Medium

ID: 33477

File Name: apache_2_2_9.nasl

Version: $Revision: 1.34 $

Type: remote

Family: Web Servers

Published: 2008/07/11

Modified: 2018/01/22

Dependencies: 48204

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C


Base Score: 5.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Vulnerability Information

CPE: cpe:/a:apache:http_server

Required KB Items: installed_sw/Apache

Exploit Available: true

Exploit Ease: Exploits are available

Reference Information

CVE: CVE-2007-6420, CVE-2008-2364, CVE-2007-6423

BID: 27236, 29653

OSVDB: 42937, 46085

Secunia: 30621

CWE: 352, 399