CVE-2008-2364

MEDIUM

Description

The ap_proxy_http_process_response function in mod_proxy_http.c in the mod_proxy module in the Apache HTTP Server 2.0.63 and 2.2.8 does not limit the number of forwarded interim responses, which allows remote HTTP servers to cause a denial of service (memory consumption) via a large number of interim responses.

References

http://svn.apache.org/viewvc/httpd/httpd/trunk/modules/proxy/mod_proxy_http.c?r1=666154&r2=666153&pathrev=666154

http://www.securityfocus.com/bid/29653

http://secunia.com/advisories/30621

https://www.redhat.com/archives/fedora-package-announce/2008-August/msg00153.html

http://secunia.com/advisories/31416

http://secunia.com/advisories/31404

http://secunia.com/advisories/31026

https://www.redhat.com/archives/fedora-package-announce/2008-August/msg00055.html

http://security.gentoo.org/glsa/glsa-200807-06.xml

http://www.securitytracker.com/id?1020267

http://secunia.com/advisories/31651

http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c01539432

http://www-01.ibm.com/support/docview.wss?uid=swg27008517

http://secunia.com/advisories/31904

http://www.mandriva.com/security/advisories?name=MDVSA-2008:195

http://www-1.ibm.com/support/docview.wss?uid=swg1PK67579

http://lists.apple.com/archives/security-announce/2008/Oct/msg00001.html

http://www.securityfocus.com/bid/31681

http://support.apple.com/kb/HT3216

http://secunia.com/advisories/32222

http://secunia.com/advisories/32685

http://rhn.redhat.com/errata/RHSA-2008-0967.html

http://www.redhat.com/support/errata/RHSA-2008-0966.html

http://www.mandriva.com/security/advisories?name=MDVSA-2008:237

http://marc.info/?l=bugtraq&m=123376588623823&w=2

http://secunia.com/advisories/33156

http://sunsolve.sun.com/search/document.do?assetkey=1-26-247666-1

http://secunia.com/advisories/33797

http://wiki.rpath.com/wiki/Advisories:rPSA-2008-0328

http://secunia.com/advisories/32838

http://lists.opensuse.org/opensuse-security-announce/2009-03/msg00001.html

http://www.ubuntu.com/usn/USN-731-1

http://secunia.com/advisories/34259

http://secunia.com/advisories/34219

http://secunia.com/advisories/34418

http://lists.opensuse.org/opensuse-security-announce/2009-03/msg00004.html

http://marc.info/?l=bugtraq&m=125631037611762&w=2

http://www.vupen.com/english/advisories/2008/2780

http://www.vupen.com/english/advisories/2009/0320

http://www.vupen.com/english/advisories/2008/1798

http://www.oracle.com/technetwork/topics/security/cpujuly2013-1899826.html

https://exchange.xforce.ibmcloud.com/vulnerabilities/42987

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A9577

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A6084

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A11713

http://www.securityfocus.com/archive/1/498567/100/0/threaded

http://www.securityfocus.com/archive/1/494858/100/0/threaded

https://lists.apache.org/thread.html/[email protected]%3Ccvs.httpd.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Ccvs.httpd.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Ccvs.httpd.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Ccvs.httpd.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Ccvs.httpd.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Ccvs.httpd.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Ccvs.httpd.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Ccvs.httpd.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Ccvs.httpd.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Ccvs.httpd.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Ccvs.httpd.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Ccvs.httpd.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Ccvs.httpd.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Ccvs.httpd.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Ccvs.httpd.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Ccvs.httpd.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Ccvs.httpd.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Ccvs.httpd.apache.org%3E

Details

Source: MITRE

Published: 2008-06-13

Updated: 2021-04-22

Type: CWE-399

Risk Information

CVSS v2.0

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

Tenable Plugins

View all (17 total)

IDNameProductFamilySeverity
69301Oracle Fusion Middleware Oracle HTTP Server Multiple VulnerabilitiesNessusWeb Servers
critical
67760Oracle Linux 3 / 4 / 5 : httpd (ELSA-2008-0967)NessusOracle Linux Local Security Checks
medium
60493Scientific Linux Security Update : httpd on SL3.x, SL4.x, SL5.x i386/x86_64NessusScientific Linux Local Security Checks
medium
50069Apache 2.0.x < 2.0.64 Multiple VulnerabilitiesNessusWeb Servers
high
41473SuSE 10 Security Update : Apache 2 (ZYPP Patch Number 6035)NessusSuSE Local Security Checks
medium
37114Mandriva Linux Security Advisory : apache (MDVSA-2008:195)NessusMandriva Local Security Checks
medium
37062CentOS 3 / 4 / 5 : httpd (CESA-2008:0967)NessusCentOS Local Security Checks
medium
36589Ubuntu 6.06 LTS / 7.10 / 8.04 LTS : apache2 vulnerabilities (USN-731-1)NessusUbuntu Local Security Checks
medium
35920openSUSE 10 Security Update : apache2 (apache2-6054)NessusSuSE Local Security Checks
medium
34751RHEL 3 / 4 / 5 : httpd (RHSA-2008:0967)NessusRed Hat Local Security Checks
medium
34374Mac OS X Multiple Vulnerabilities (Security Update 2008-007)NessusMacOS X Local Security Checks
critical
33840Fedora 9 : httpd-2.2.9-1.fc9 (2008-6393)NessusFedora Local Security Checks
medium
33839Fedora 8 : httpd-2.2.9-1.fc8 (2008-6314)NessusFedora Local Security Checks
medium
33477Apache 2.2.x < 2.2.9 Multiple Vulnerabilities (DoS, XSS)NessusWeb Servers
medium
33473GLSA-200807-06 : Apache: Denial of ServiceNessusGentoo Local Security Checks
medium
33242FreeBSD : apache -- multiple vulnerabilities (c84dc9ad-41f7-11dd-a4f9-00163e000016)NessusFreeBSD Local Security Checks
medium
4579Apache < 2.2.9 Multiple VulnerabilitiesNessus Network MonitorWeb Servers
high