PHP 5.x < 5.2.6 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 4493


The remote web server uses a version of PHP that is affected by multiple flaws.


According to its banner, the version of PHP 5.x installed on the remote host is older than 5.2.6. Such versions may be affected by the following issues :

- A stack buffer overflow in FastCGI SAPI.
- An integer overflow in printf().
- An unspecified security issue tracked by CVE-2008-0599.
- A safe_mode bypass in cURL.
- Incomplete handling of multibyte chars inside escapeshellcmd().
- Issues in the bundled PCRE fixed by version 7.6.


Upgrade to version 5.2.6 or higher.

See Also

Plugin Details

Severity: High

ID: 4493

File Name: 4493.prm

Family: Web Servers

Published: 2008/05/02

Modified: 2016/11/23

Dependencies: 8682

Nessus ID: 32123

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C


Base Score: 7.3

Temporal Score: 6.8


Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2008/05/02

Vulnerability Publication Date: 2008/05/02

Reference Information

CVE: CVE-2007-4850, CVE-2008-0674, CVE-2008-2050, CVE-2008-2051, CVE-2008-0599

BID: 29009