PHP 5.x < 5.2.6 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 4493

Synopsis

The remote web server uses a version of PHP that is affected by multiple flaws.

Description

According to its banner, the version of PHP 5.x installed on the remote host is older than 5.2.6. Such versions may be affected by the following issues :

- A stack buffer overflow in FastCGI SAPI.
- An integer overflow in printf().
- An unspecified security issue tracked by CVE-2008-0599.
- A safe_mode bypass in cURL.
- Incomplete handling of multibyte chars inside escapeshellcmd().
- Issues in the bundled PCRE fixed by version 7.6.

Solution

Upgrade to version 5.2.6 or higher.

See Also

http://www.openwall.com/lists/oss-security/2008/05/02/2

http://www.php.net/releases/5_2_6.php

Plugin Details

Severity: High

ID: 4493

File Name: 4493.prm

Family: Web Servers

Published: 2008/05/02

Modified: 2016/11/23

Dependencies: 8682

Nessus ID: 32123

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2008/05/02

Vulnerability Publication Date: 2008/05/02

Reference Information

CVE: CVE-2007-4850, CVE-2008-0674, CVE-2008-2050, CVE-2008-2051, CVE-2008-0599

BID: 29009