PHP 5.x < 5.2.0 Multiple Vulnerabilities

high Nessus Network Monitor Plugin ID 4444


The remote web server uses a version of PHP that is affected by multiple buffer overflows.


According to its banner, the version of PHP 5.x installed on the remote host is older than 5.2.0. Such versions may be affected by several buffer overflows To exploit these issues, an attacker would need the ability to upload an arbitrary PHP script to the remote server, or to be able to manipulate several variables processed by some PHP functions such as htmlentities().


Upgrade to version 5.2.0 or higher.

See Also

Plugin Details

Severity: High

ID: 4444

Family: Web Servers

Published: 3/25/2008

Updated: 3/6/2019

Nessus ID: 31649

Risk Information


Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:H/RL:OF/RC:C


Risk Factor: High

Base Score: 7.3

Temporal Score: 7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 11/2/2006

Vulnerability Publication Date: 11/2/2006

Reference Information

CVE: CVE-2006-1015, CVE-2006-1549, CVE-2006-2660, CVE-2006-4486, CVE-2006-4625, CVE-2006-4812, CVE-2006-5465, CVE-2006-5706, CVE-2006-7205, CVE-2007-0448, CVE-2007-1381, CVE-2007-1584, CVE-2007-1888, CVE-2007-2844, CVE-2007-5424

BID: 20349, 20879, 49634