PHP 5.x < 5.2.0 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 4444

Synopsis

The remote web server uses a version of PHP that is affected by multiple buffer overflows.

Description

According to its banner, the version of PHP 5.x installed on the remote host is older than 5.2.0. Such versions may be affected by several buffer overflows To exploit these issues, an attacker would need the ability to upload an arbitrary PHP script to the remote server, or to be able to manipulate several variables processed by some PHP functions such as htmlentities().

Solution

Upgrade to version 5.2.0 or higher.

See Also

http://www.php.net/releases/5_2_0.php

http://www.hardened-php.net/advisory_092006.133.html

Plugin Details

Severity: High

ID: 4444

Family: Web Servers

Published: 2008/03/25

Modified: 2018/09/16

Dependencies: 8682

Nessus ID: 31649

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 7

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2006/11/02

Vulnerability Publication Date: 2006/11/02

Reference Information

CVE: CVE-2006-1015, CVE-2006-1549, CVE-2006-2660, CVE-2006-4486, CVE-2006-4625, CVE-2006-4812, CVE-2006-5465, CVE-2006-5706, CVE-2006-7205, CVE-2007-0448, CVE-2007-1381, CVE-2007-1584, CVE-2007-1888, CVE-2007-2844, CVE-2007-5424

BID: 20349, 20879, 49634