CVE-2006-2660

low
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Buffer consumption vulnerability in the tempnam function in PHP 5.1.4 and 4.x before 4.4.3 allows local users to bypass restrictions and create PHP files with fixed names in other directories via a pathname argument longer than MAXPATHLEN, which prevents a unique string from being appended to the filename.

References

http://archives.neohapsis.com/archives/fulldisclosure/2006-06/0209.html

http://cvs.php.net/viewcvs.cgi/php-src/NEWS?view=markup&rev=1.1247.2.920.2.134

http://secunia.com/advisories/21125

http://securityreason.com/securityalert/1069

http://securitytracker.com/id?1016271

http://www.mandriva.com/security/advisories?name=MDKSA-2006:122

http://www.securityfocus.com/archive/1/436785/100/0/threaded

http://www.ubuntu.com/usn/usn-320-1

https://exchange.xforce.ibmcloud.com/vulnerabilities/27049

Details

Source: MITRE

Published: 2006-06-13

Updated: 2018-10-30

Risk Information

CVSS v2

Base Score: 2.1

Vector: AV:L/AC:L/Au:N/C:N/I:P/A:N

Impact Score: 2.9

Exploitability Score: 3.9

Severity: LOW

Tenable Plugins

View all (5 total)

IDNameProductFamilySeverity
4444PHP 5.x < 5.2.0 Multiple VulnerabilitiesNessus Network MonitorWeb Servers
high
31649PHP 5.x < 5.2 Multiple VulnerabilitiesNessusCGI abuses
high
27897Ubuntu 5.04 / 5.10 / 6.06 LTS : php4, php5 vulnerabilities (USN-320-1)NessusUbuntu Local Security Checks
high
22268PHP < 4.4.3 / 5.1.4 Multiple VulnerabilitiesNessusCGI abuses
high
22053Mandrake Linux Security Advisory : php (MDKSA-2006:122)NessusMandriva Local Security Checks
critical