PHP 5.x < 5.2 Multiple Vulnerabilities

High Nessus Plugin ID 31649

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 6.7

Synopsis

The remote web server uses a version of PHP that is affected by multiple buffer overflows.

Description

According to its banner, the version of PHP 5.x installed on the remote host is older than 5.2. Such versions may be affected by several buffer overflows.

To exploit these issues, an attacker would need the ability to upload an arbitrary PHP script on the remote server or to manipulate several variables processed by some PHP functions such as 'htmlentities().'

Solution

Upgrade to PHP version 5.2.0 or later.

See Also

http://www.hardened-php.net/advisory_092006.133.html

http://www.php.net/releases/5_2_0.php

Plugin Details

Severity: High

ID: 31649

File Name: php_5_2_0.nasl

Version: 1.27

Type: remote

Family: CGI abuses

Published: 2008/03/25

Updated: 2018/07/24

Dependencies: 48243

Risk Information

Risk Factor: High

VPR Score: 6.7

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2006/11/02

Vulnerability Publication Date: 2006/11/02

Reference Information

CVE: CVE-2006-1015, CVE-2006-1549, CVE-2006-2660, CVE-2006-4486, CVE-2006-4625, CVE-2006-4812, CVE-2006-5465, CVE-2006-5706, CVE-2006-7205, CVE-2007-0448, CVE-2007-1381, CVE-2007-1584, CVE-2007-1888, CVE-2007-2844, CVE-2007-5424

BID: 20349, 20879, 49634

CWE: 94, 119, 399