PHP 5.x < 5.2.5 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 4281


The remote web server uses a version of PHP that is affected by multiple flaws.


According to its banner, the version of PHP 5.x installed on the remote host is older than 5.2.5. Such versions may be affected by various issues, including but not limited to several buffer overflows.


Upgrade to version 5.2.5 or higher.

See Also

Plugin Details

Severity: High

ID: 4281

Family: Web Servers

Published: 2005/04/01

Updated: 2019/03/06

Dependencies: 8682

Nessus ID: 28181

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2005/03/25

Vulnerability Publication Date: 2005/03/31

Reference Information

CVE: CVE-2007-4825, CVE-2007-4887

BID: 26403, 69246