Mantis < 0.19.3 Multiple Injection Vulnerabilities

high Nessus Network Monitor Plugin ID 3173
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server contains a script that is vulnerable to a SQL injection attack.

Description

The remote host seems to be running a vulnerable version of Mantis, a bug tracker web application written in PHP. It is reported that versions up to 0.19.3 are prone to multiple HTML and SQL injection flaws that would allow an attacker to upload or execute arbitrary code as well as manipulate database data.

Solution

Upgrade to version 0.19.3 or higher.

Plugin Details

Severity: High

ID: 3173

Family: CGI

Published: 8/19/2005

Updated: 3/6/2019

Dependencies: 1442

Risk Information

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.3

Temporal Score: 7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:mantis:mantis:*:*:*:*:*:*:*:*

Reference Information

CVE: CVE-2005-2556, CVE-2005-2557, CVE-2005-3335, CVE-2005-3091, CVE-2005-3336, CVE-2005-3338, CVE-2005-3339

BID: 15212, 15227, 14604, 15210