Apache < 1.3.29 Multiple Vulnerabilities

high Nessus Network Monitor Plugin ID 2174
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote host is vulnerable to a buffer overflow.


The remote host appears to be running a version of Apache which is older than 1.3.29 There are several flaws in this version that may allow an attacker to possibly execute arbitrary code through mod_alias and mod_rewrite.


Upgrade to version 1.3.29 or higher.

See Also



Plugin Details

Severity: High

ID: 2174

Family: Web Servers

Published: 8/30/2004

Updated: 3/6/2019

Dependencies: 3057

Nessus ID: 11915

Risk Information


Risk Factor: High

Base Score: 7.2

Temporal Score: 6.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C


Risk Factor: High

Base Score: 8.4

Temporal Score: 8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:apache:http_server:1.0:*:*:*:*:*:*:*

Reference Information

CVE: CVE-2003-0542, CVE-2003-0789, CVE-2002-0061, CVE-2004-0087, CVE-2004-0090, CVE-2004-0092, CVE-2004-0085, CVE-2004-0086, CVE-2004-0088

BID: 4335, 8911, 9504, 8926