Apache < 1.3.29 Multiple Vulnerabilities

high Nessus Network Monitor Plugin ID 2174

Synopsis

The remote host is vulnerable to a buffer overflow.

Description

The remote host appears to be running a version of Apache which is older than 1.3.29 There are several flaws in this version that may allow an attacker to possibly execute arbitrary code through mod_alias and mod_rewrite.

Solution

Upgrade to version 1.3.29 or higher.

See Also

http://www.apache.org/dist/httpd/Announcement.html

http://www.securityfocus.com/archive/1/342674/30/0/threaded

Plugin Details

Severity: High

ID: 2174

Family: Web Servers

Published: 8/30/2004

Updated: 3/6/2019

Nessus ID: 11915

Risk Information

CVSS v2

Risk Factor: High

Base Score: 7.2

Temporal Score: 6.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.4

Temporal Score: 8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:apache:http_server:1.0:*:*:*:*:*:*:*

Reference Information

CVE: CVE-2003-0542, CVE-2003-0789, CVE-2002-0061, CVE-2004-0087, CVE-2004-0090, CVE-2004-0092, CVE-2004-0085, CVE-2004-0086, CVE-2004-0088

BID: 4335, 8911, 9504, 8926