Apache < 1.3.29 Multiple Modules Local Overflow

High Nessus Plugin ID 11915


The remote web server is affected by multiple local buffer overflow vulnerabilities.


The remote host appears to be running a version of the Apache web server which is older than 1.3.29. Such versions are reportedly affected by local buffer overflow vulnerabilities in the mod_alias and mod_rewrite modules. An attacker could exploit these vulnerabilities to execute arbitrary code in the context of the affected application.

*** Note that Nessus solely relied on the version number
*** of the remote server to issue this warning. This might
*** be a false positive


Upgrade to Apache web server version 1.3.29 or later.

See Also


Plugin Details

Severity: High

ID: 11915

File Name: apache_1_3_29.nasl

Version: $Revision: 1.25 $

Type: remote

Family: Web Servers

Published: 2003/11/01

Modified: 2018/01/23

Dependencies: 48204

Risk Information

Risk Factor: High


Base Score: 7.2

Temporal Score: 5.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server

Required KB Items: installed_sw/Apache

Exploit Available: false

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 2003/10/29

Reference Information

CVE: CVE-2003-0542

BID: 8911

OSVDB: 2733, 7611

Secunia: 10096, 10845, 17311

CWE: 119