openSUSE Security Update : MozillaThunderbird (openSUSE-2017-345)

Medium Nessus Plugin ID 97748


The remote openSUSE host is missing a security update.


This update to Mozilla Thunderbird 45.8.0 fixes security issues and bugs.

The following security issues from advisory MFSA 2017-07 were fixed.
(boo#1028391) In general, these flaws cannot be exploited through email in Thunderbird because scripting is disabled when reading mail, but are potentially risks in browser or browser-like contexts :

- CVE-2017-5400: asm.js JIT-spray bypass of ASLR and DEP

- CVE-2017-5401: Memory Corruption when handling ErrorResult

- CVE-2017-5402: Use-after-free working with events in FontFace objects (bmo#1334876)

- CVE-2017-5404: Use-after-free working with ranges in selections

- CVE-2017-5407: Pixel and history stealing via floating-point timing side channel with SVG filters

- CVE-2017-5410: Memory corruption during JavaScript garbage collection incremental sweeping

- CVE-2017-5408: Cross-origin reading of video captions in violation of CORS

- CVE-2017-5405: FTP response codes can cause use of uninitialized values for ports (bmo#1336699)

- CVE-2017-5398: Memory safety bugs fixed in Thunderbird 45.8

The following non-security issues were fixed :

- crash when viewing certain IMAP messages


Update the affected MozillaThunderbird packages.

See Also

Plugin Details

Severity: Medium

ID: 97748

File Name: openSUSE-2017-345.nasl

Version: $Revision: 3.2 $

Type: local

Agent: unix

Published: 2017/03/15

Modified: 2017/03/17

Dependencies: 12634

Risk Information

Risk Factor: Medium

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:MozillaThunderbird, p-cpe:/a:novell:opensuse:MozillaThunderbird-buildsymbols, p-cpe:/a:novell:opensuse:MozillaThunderbird-debuginfo, p-cpe:/a:novell:opensuse:MozillaThunderbird-debugsource, p-cpe:/a:novell:opensuse:MozillaThunderbird-devel, p-cpe:/a:novell:opensuse:MozillaThunderbird-translations-common, p-cpe:/a:novell:opensuse:MozillaThunderbird-translations-other, cpe:/o:novell:opensuse:42.1, cpe:/o:novell:opensuse:42.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2017/03/14

Reference Information

CVE: CVE-2017-5398, CVE-2017-5400, CVE-2017-5401, CVE-2017-5402, CVE-2017-5404, CVE-2017-5405, CVE-2017-5407, CVE-2017-5408, CVE-2017-5410