FreeBSD : ikiwiki -- authentication bypass vulnerability (7b35a77a-0151-11e7-ae1b-002590263bf5)

High Nessus Plugin ID 97546


The remote FreeBSD host is missing a security-related update.


ikiwiki reports :

The ikiwiki maintainers discovered further flaws similar to CVE-2016-9646 in the passwordauth plugin's use of CGI::FormBuilder, with a more serious impact :

An attacker who can log in to a site with a password can log in as a different and potentially more privileged user.

An attacker who can create a new account can set arbitrary fields in the user database for that account


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 97546

File Name: freebsd_pkg_7b35a77a015111e7ae1b002590263bf5.nasl

Version: $Revision: 3.1 $

Type: local

Published: 2017/03/06

Modified: 2017/03/06

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:ikiwiki, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2017/03/05

Vulnerability Publication Date: 2017/01/11

Reference Information

CVE: CVE-2017-0356