CVE-2017-0356

HIGH

Description

A flaw, similar to to CVE-2016-9646, exists in ikiwiki before 3.20170111, in the passwordauth plugin's use of CGI::FormBuilder, allowing an attacker to bypass authentication via repeated parameters.

References

http://www.securityfocus.com/bid/95420

https://ikiwiki.info/security/#cve-2017-0356

https://marc.info/?l=oss-security&m=148418234314276&w=2

https://www.debian.org/security/2017/dsa-3760

Details

Source: MITRE

Published: 2018-04-13

Updated: 2018-05-18

Type: CWE-287

Risk Information

CVSS v2.0

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 3.9

Severity: CRITICAL