Tenable Nessus 6.x < 6.9.3 Multiple Stored XSS

medium Nessus Plugin ID 96833
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


An application running on the remote host is affected by multiple cross-site scripting vulnerabilities.


According to its self-reported version, the Tenable Nessus application running on the remote host is prior to 6.9.3. It is, therefore, affected by multiple stored cross-site scripting (XSS) vulnerabilities due to improper validation of user-supplied input. An authenticated, remote attacker can exploit these, via a specially crafted request, to execute arbitrary script code in a user's browser session.


Upgrade to Tenable Nessus version 6.9.3 or later.

See Also


Plugin Details

Severity: Medium

ID: 96833

File Name: nessus_tns_2017_01.nasl

Version: 1.7

Type: remote

Published: 1/27/2017

Updated: 11/13/2019

Dependencies: nessus_detect.nasl

Risk Information

CVSS Score Source: CVE-2017-5179


Risk Factor: Low

Score: 3


Risk Factor: Low

Base Score: 3.5

Temporal Score: 3

Vector: AV:N/AC:M/Au:S/C:N/I:P/A:N

Temporal Vector: E:H/RL:OF/RC:C


Risk Factor: Medium

Base Score: 5.4

Temporal Score: 5.2

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:tenable:nessus

Required KB Items: installed_sw/nessus

Exploit Ease: No exploit is required

Patch Publication Date: 1/4/2017

Vulnerability Publication Date: 1/4/2017

Reference Information

CVE: CVE-2017-5179

BID: 95307