openSUSE Security Update : zlib (openSUSE-2017-47)

High Nessus Plugin ID 96377


The remote openSUSE host is missing a security update.


This update for zlib fixes the following issues :

- CVE-2016-9843: Big-endian out-of-bounds pointer (bsc#1013882)

- CVE-2016-9842: Undefined Left Shift of Negative Number (bsc#1003580)

- CVE-2016-9840 CVE-2016-9841: Out-of-bounds pointer arithmetic in inftrees.c (bsc#1003579)

- Incompatible declarations for external linkage function deflate (bsc#1003577)

This update was imported from the SUSE:SLE-12:Update update project.


Update the affected zlib packages.

See Also

Plugin Details

Severity: High

ID: 96377

File Name: openSUSE-2017-47.nasl

Version: $Revision: 3.4 $

Type: local

Agent: unix

Published: 2017/01/10

Modified: 2018/01/26

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P


Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libz1, p-cpe:/a:novell:opensuse:libz1-32bit, p-cpe:/a:novell:opensuse:libz1-debuginfo, p-cpe:/a:novell:opensuse:libz1-debuginfo-32bit, p-cpe:/a:novell:opensuse:zlib-debugsource, p-cpe:/a:novell:opensuse:zlib-devel, p-cpe:/a:novell:opensuse:zlib-devel-32bit, p-cpe:/a:novell:opensuse:zlib-devel-static, p-cpe:/a:novell:opensuse:zlib-devel-static-32bit, cpe:/o:novell:opensuse:42.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2017/01/07

Reference Information

CVE: CVE-2016-9840, CVE-2016-9841, CVE-2016-9842, CVE-2016-9843