FreeBSD : hdf5 -- multiple vulnerabilities (91e039ed-d689-11e6-9171-14dae9d210b8)

Medium Nessus Plugin ID 96369


The remote FreeBSD host is missing one or more security-related updates.


Talos Security reports :

- CVE-2016-4330 (TALOS-2016-0176) - HDF5 Group libhdf5 H5T_ARRAY Code Execution Vulnerability

- CVE-2016-4331 (TALOS-2016-0177) - HDF5 Group libhdf5 H5Z_NBIT Code Execution Vulnerability

- CVE-2016-4332 (TALOS-2016-0178) - HDF5 Group libhdf5 Shareable Message Type Code Execution Vulnerability

- CVE-2016-4333 (TALOS-2016-0179) - HDF5 Group libhdf5 H5T_COMPOUND Code Execution Vulnerability


Update the affected packages.

See Also

Plugin Details

Severity: Medium

ID: 96369

File Name: freebsd_pkg_91e039edd68911e6917114dae9d210b8.nasl

Version: $Revision: 3.1 $

Type: local

Published: 2017/01/10

Modified: 2017/01/10

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.9

Vector: CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C


Base Score: 8.6

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:hdf5, p-cpe:/a:freebsd:freebsd:hdf5-18, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2017/01/09

Vulnerability Publication Date: 2016/11/17

Reference Information

CVE: CVE-2016-4330, CVE-2016-4331, CVE-2016-4332, CVE-2016-4333