FreeBSD : libvncserver -- multiple buffer overflows (64be967a-d379-11e6-a071-001e67f15f5a)

High Nessus Plugin ID 96367


The remote FreeBSD host is missing a security-related update.


libvnc server reports :

Two unrelated buffer overflows can be used by a malicious server to overwrite parts of the heap and crash the client (or possibly execute arbitrary code).


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 96367

File Name: freebsd_pkg_64be967ad37911e6a071001e67f15f5a.nasl

Version: $Revision: 3.1 $

Type: local

Published: 2017/01/10

Modified: 2017/01/10

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P


Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:libvncserver, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2017/01/09

Vulnerability Publication Date: 2016/11/24

Reference Information

CVE: CVE-2016-9941, CVE-2016-9942