CVE-2016-9941

HIGH

Description

Heap-based buffer overflow in rfbproto.c in LibVNCClient in LibVNCServer before 0.9.11 allows remote servers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted FramebufferUpdate message containing a subrectangle outside of the client drawing area.

References

http://www.debian.org/security/2017/dsa-3753

http://www.securityfocus.com/bid/95170

https://github.com/LibVNC/libvncserver/pull/137

https://github.com/LibVNC/libvncserver/releases/tag/LibVNCServer-0.9.11

https://lists.debian.org/debian-lts-announce/2019/10/msg00042.html

https://security.gentoo.org/glsa/201702-24

https://usn.ubuntu.com/4587-1/

Details

Source: MITRE

Published: 2016-12-31

Updated: 2020-10-23

Type: CWE-119

Risk Information

CVSS v2.0

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 3.9

Severity: CRITICAL