GLSA-201701-03 : libarchive: Multiple vulnerabilities

High Nessus Plugin ID 96234


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201701-03 (libarchive: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in libarchive. Please review the CVE identifiers referenced below for details.
Impact :

A remote attacker could entice a user to open a specially crafted archive file possibly resulting in the execution of arbitrary code with the privileges of the process or a Denial of Service condition.
Workaround :

There is no known workaround at this time.


All libarchive users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-arch/libarchive-3.2.2'

See Also

Plugin Details

Severity: High

ID: 96234

File Name: gentoo_GLSA-201701-03.nasl

Version: $Revision: 3.1 $

Type: local

Published: 2017/01/03

Modified: 2017/01/03

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P


Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:libarchive, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2017/01/01

Reference Information

CVE: CVE-2015-2304, CVE-2015-8915, CVE-2015-8916, CVE-2015-8917, CVE-2015-8918, CVE-2015-8919, CVE-2015-8920, CVE-2015-8921, CVE-2015-8922, CVE-2015-8923, CVE-2015-8924, CVE-2015-8925, CVE-2015-8926, CVE-2015-8927, CVE-2015-8928, CVE-2015-8929, CVE-2015-8930, CVE-2015-8931, CVE-2015-8932, CVE-2015-8933, CVE-2015-8934, CVE-2016-1541, CVE-2016-4300, CVE-2016-4301, CVE-2016-4302, CVE-2016-4809, CVE-2016-5418, CVE-2016-5844, CVE-2016-6250, CVE-2016-7166, CVE-2016-8687, CVE-2016-8688, CVE-2016-8689

GLSA: 201701-03