CVE-2015-8927

MEDIUM

Description

The trad_enc_decrypt_update function in archive_read_support_format_zip.c in libarchive before 3.2.0 allows remote attackers to cause a denial of service (out-of-bounds heap read and crash) via a crafted zip file, related to reading the password.

References

http://www.openwall.com/lists/oss-security/2016/06/17/2

http://www.openwall.com/lists/oss-security/2016/06/17/5

http://www.securityfocus.com/bid/91329

https://blog.fuzzing-project.org/47-Many-invalid-memory-access-issues-in-libarchive.html

https://github.com/libarchive/libarchive/issues/523

https://security.gentoo.org/glsa/201701-03

Details

Source: MITRE

Published: 2016-09-20

Updated: 2017-07-01

Type: CWE-125

Risk Information

CVSS v2.0

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3.0

Base Score: 5.5

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 1.8

Severity: MEDIUM