openSUSE Security Update : gd (openSUSE-2016-1281)

High Nessus Plugin ID 94753


The remote openSUSE host is missing a security update.


This update for gd fixes the following security issues :

- CVE-2016-7568: A specially crafted image file could cause an application crash or potentially execute arbitrary code when the image is converted to webp (bsc#1001900)

- CVE-2016-8670: Stack Buffer Overflow in GD dynamicGetbuf (bsc#1004924)

- CVE-2016-6911: Check for out-of-bound read in dynamicGetbuf() (bsc#1005274)

This update was imported from the SUSE:SLE-12:Update update project.


Update the affected gd packages.

See Also

Plugin Details

Severity: High

ID: 94753

File Name: openSUSE-2016-1281.nasl

Version: $Revision: 2.1 $

Type: local

Agent: unix

Published: 2016/11/14

Modified: 2016/11/14

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P


Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:gd, p-cpe:/a:novell:opensuse:gd-32bit, p-cpe:/a:novell:opensuse:gd-debuginfo, p-cpe:/a:novell:opensuse:gd-debuginfo-32bit, p-cpe:/a:novell:opensuse:gd-debugsource, p-cpe:/a:novell:opensuse:gd-devel, cpe:/o:novell:opensuse:42.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2016/11/10

Reference Information

CVE: CVE-2016-6911, CVE-2016-7568, CVE-2016-8670