CVE-2016-6911

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The dynamicGetbuf function in the GD Graphics Library (aka libgd) before 2.2.4 allows remote attackers to cause a denial of service (out-of-bounds read) via a crafted TIFF image.

References

http://www.debian.org/security/2016/dsa-3693

http://www.securityfocus.com/bid/95840

https://github.com/libgd/libgd/blob/gd-2.2.4/CHANGELOG.md

https://github.com/libgd/libgd/commit/4859d69e07504d4b0a4bdf9bcb4d9e3769ca35ae

https://github.com/libgd/libgd/pull/353

Details

Source: MITRE

Published: 2017-01-26

Updated: 2017-11-04

Type: CWE-125

Risk Information

CVSS v2

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 5.5

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 1.8

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:libgd:libgd:*:*:*:*:*:*:*:* versions up to 2.2.3 (inclusive)

Tenable Plugins

View all (17 total)

IDNameProductFamilySeverity
140916EulerOS 2.0 SP3 : gd (EulerOS-SA-2020-2149)NessusHuawei Local Security Checks
medium
135626EulerOS Virtualization 3.0.2.2 : gd (EulerOS-SA-2020-1464)NessusHuawei Local Security Checks
high
131801EulerOS 2.0 SP5 : gd (EulerOS-SA-2019-2527)NessusHuawei Local Security Checks
medium
119985SUSE SLES12 Security Update : php5 (SUSE-SU-2016:2766-1)NessusSuSE Local Security Checks
critical
119984SUSE SLES12 Security Update : php7 (SUSE-SU-2016:2683-1)NessusSuSE Local Security Checks
critical
96026Fedora 24 : gd (2016-e45a7e7b13)NessusFedora Local Security Checks
critical
95678Fedora 25 : gd (2016-722c0afc64)NessusFedora Local Security Checks
critical
94952openSUSE Security Update : php5 (openSUSE-2016-1321)NessusSuSE Local Security Checks
critical
94944openSUSE Security Update : php5 (openSUSE-2016-1308)NessusSuSE Local Security Checks
critical
94753openSUSE Security Update : gd (openSUSE-2016-1281)NessusSuSE Local Security Checks
critical
94466Ubuntu 12.04 LTS / 14.04 LTS / 16.04 LTS / 16.10 : libgd2 vulnerabilities (USN-3117-1)NessusUbuntu Local Security Checks
critical
94455SUSE SLES11 Security Update : php53 (SUSE-SU-2016:2681-1)NessusSuSE Local Security Checks
critical
94435SUSE SLES11 Security Update : gd (SUSE-SU-2016:2670-1)NessusSuSE Local Security Checks
critical
94434SUSE SLED12 / SLES12 Security Update : gd (SUSE-SU-2016:2668-1)NessusSuSE Local Security Checks
critical
94243openSUSE Security Update : php5 (openSUSE-2016-1221)NessusSuSE Local Security Checks
critical
94113Debian DLA-665-1 : libgd2 security updateNessusDebian Local Security Checks
critical
94079Debian DSA-3693-1 : libgd2 - security updateNessusDebian Local Security Checks
critical