openSUSE Security Update : wget (openSUSE-2016-1067)

high Nessus Plugin ID 93430
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for wget fixes the following issues :

- Fix for HTTP to a FTP redirection file name confusion vulnerability (bsc#984060, CVE-2016-4971).

- Work around a libidn vulnerability (bsc#937096, CVE-2015-2059).

- Fix for wget fails with basicauth: Failed writing HTTP request: Bad file descriptor (bsc#958342)

This update was imported from the SUSE:SLE-12:Update update project.

Solution

Update the affected wget packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=937096

https://bugzilla.opensuse.org/show_bug.cgi?id=958342

https://bugzilla.opensuse.org/show_bug.cgi?id=984060

Plugin Details

Severity: High

ID: 93430

File Name: openSUSE-2016-1067.nasl

Version: 2.5

Type: local

Agent: unix

Published: 9/12/2016

Updated: 1/19/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: High

Score: 7.4

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.9

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:wget, p-cpe:/a:novell:opensuse:wget-debuginfo, p-cpe:/a:novell:opensuse:wget-debugsource, cpe:/o:novell:opensuse:42.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 9/9/2016

Reference Information

CVE: CVE-2015-2059, CVE-2016-4971