openSUSE Security Update : expat (openSUSE-2016-695)

High Nessus Plugin ID 91530


The remote openSUSE host is missing a security update.


This update for expat fixes the following issues :

Security issue fixed :

- CVE-2016-0718: Fix Expat XML parser that mishandles certain kinds of malformed input documents. (bsc#979441)

- CVE-2015-1283: Fix multiple integer overflows.
(bnc#980391) This update was imported from the SUSE:SLE-12:Update update project.


Update the affected expat packages.

See Also

Plugin Details

Severity: High

ID: 91530

File Name: openSUSE-2016-695.nasl

Version: $Revision: 2.4 $

Type: local

Agent: unix

Published: 2016/06/09

Modified: 2016/10/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P


Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:expat, p-cpe:/a:novell:opensuse:expat-debuginfo, p-cpe:/a:novell:opensuse:expat-debuginfo-32bit, p-cpe:/a:novell:opensuse:expat-debugsource, p-cpe:/a:novell:opensuse:libexpat-devel, p-cpe:/a:novell:opensuse:libexpat-devel-32bit, p-cpe:/a:novell:opensuse:libexpat1, p-cpe:/a:novell:opensuse:libexpat1-32bit, p-cpe:/a:novell:opensuse:libexpat1-debuginfo, p-cpe:/a:novell:opensuse:libexpat1-debuginfo-32bit, cpe:/o:novell:opensuse:42.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2016/06/08

Reference Information

CVE: CVE-2015-1283, CVE-2016-0718