CVE-2015-1283

MEDIUM
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Multiple integer overflows in the XML_GetBuffer function in Expat through 2.1.0, as used in Google Chrome before 44.0.2403.89 and other products, allow remote attackers to cause a denial of service (heap-based buffer overflow) or possibly have unspecified other impact via crafted XML data, a related issue to CVE-2015-2716.

References

http://googlechromereleases.blogspot.com/2015/07/stable-channel-update_21.html

http://lists.opensuse.org/opensuse-security-announce/2015-07/msg00038.html

http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00064.html

http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00006.html

http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00007.html

http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00010.html

http://rhn.redhat.com/errata/RHSA-2015-1499.html

http://www.debian.org/security/2015/dsa-3315

http://www.debian.org/security/2015/dsa-3318

http://www.oracle.com/technetwork/topics/security/bulletinjul2016-3090568.html

http://www.securityfocus.com/bid/75973

http://www.securitytracker.com/id/1033031

http://www.ubuntu.com/usn/USN-2726-1

https://code.google.com/p/chromium/issues/detail?id=492052

https://codereview.chromium.org/1224303003

https://security.gentoo.org/glsa/201603-09

https://security.gentoo.org/glsa/201701-21

https://source.android.com/security/bulletin/2016-11-01.html

https://www.tenable.com/security/tns-2016-20

Details

Source: MITRE

Published: 2015-07-23

Updated: 2021-01-25

Type: CWE-189

Risk Information

CVSS v2

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:google:chrome:*:*:*:*:*:*:*:* versions up to 43.0.2357.134 (inclusive)

Configuration 2

OR

cpe:2.3:a:libexpat_project:libexpat:*:*:*:*:*:*:*:* versions up to 2.1.0 (inclusive)

Tenable Plugins

View all (34 total)

IDNameProductFamilySeverity
144286IBM HTTP Server 8.5.0.0 <= 8.5.5.6 / 8.0.0.0 <= 8.0.0.11 / 7.0.0.0 <= 7.0.0.37 / 6.1.0.0 <= 6.1.0.47 (535175)NessusWeb Servers
high
129256EulerOS 2.0 SP3 : expat (EulerOS-SA-2019-2063)NessusHuawei Local Security Checks
high
126869EulerOS 2.0 SP2 : expat (EulerOS-SA-2019-1742)NessusHuawei Local Security Checks
high
126540EulerOS Virtualization for ARM 64 3.0.2.0 : expat (EulerOS-SA-2019-1698)NessusHuawei Local Security Checks
high
126293EulerOS 2.0 SP5 : expat (EulerOS-SA-2019-1666)NessusHuawei Local Security Checks
high
125546Juniper JSA10904NessusJunos Local Security Checks
high
106497pfSense < 2.2.5 Multiple Vulnerabilities (SA-15_08)NessusFirewalls
high
100027Apple iTunes < 12.6 Multiple Vulnerabilities (macOS) (credentialed check)NessusMacOS X Local Security Checks
critical
100026Apple iTunes < 12.6 Multiple Vulnerabilities (uncredentialed check)NessusPeer-To-Peer File Sharing
critical
100025Apple iTunes < 12.6 Multiple Vulnerabilities (credentialed check)NessusWindows
critical
97446F5 Networks BIG-IP : Expat XML library vulnerability (K50459349)NessusF5 Networks Local Security Checks
high
96415GLSA-201701-21 : Expat: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
96337Tenable Passive Vulnerability Scanner 5.x < 5.2.0 Multiple Vulnerabilities (SWEET32)NessusMisc.
critical
96092Slackware 13.0 / 13.1 / 13.37 / 14.0 / 14.1 / 14.2 / current : expat (SSA:2016-359-01)NessusSlackware Local Security Checks
critical
93971F5 Networks BIG-IP : Expat XML library vulnerability (K15104541)NessusF5 Networks Local Security Checks
high
92894FreeBSD : FreeBSD -- Multiple integer overflows in expat (libbsdxml) XML parser (0da8a68e-600a-11e6-a6c3-14dae9d210b8)NessusFreeBSD Local Security Checks
medium
91729Ubuntu 12.04 LTS : xmlrpc-c vulnerabilities (USN-3013-1)NessusUbuntu Local Security Checks
critical
91652SUSE SLED12 / SLES12 Security Update : expat (SUSE-SU-2016:1508-1)NessusSuSE Local Security Checks
critical
91556SUSE SLES11 Security Update : expat (SUSE-SU-2016:1512-1)NessusSuSE Local Security Checks
critical
91530openSUSE Security Update : expat (openSUSE-2016-695)NessusSuSE Local Security Checks
critical
91407openSUSE Security Update : expat (openSUSE-2016-660)NessusSuSE Local Security Checks
critical
89902GLSA-201603-09 : Chromium: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
86018IBM HTTP Server 6.1 <= 6.1.0.47 (FP47) / 7.0 < 7.0.0.39 (FP39) / 8.0 < 8.0.0.12 (FP12) / 8.5 < 8.5.5.7 (FP7) Multiple VulnerabilitiesNessusWeb Servers
high
8853Google Chrome < 44.0.2403.89 Multiple VulnerabilitiesNessus Network MonitorWeb Clients
high
85724Ubuntu 12.04 LTS / 14.04 LTS / 15.04 : expat vulnerability (USN-2726-1)NessusUbuntu Local Security Checks
medium
85240Ubuntu 14.04 LTS / 15.04 : oxide-qt vulnerabilities (USN-2677-1)NessusUbuntu Local Security Checks
critical
85039RHEL 6 : chromium-browser (RHSA-2015:1499)NessusRed Hat Local Security Checks
critical
85032Debian DSA-3318-1 : expat - security updateNessusDebian Local Security Checks
medium
85003openSUSE Security Update : Chromium (openSUSE-2015-513)NessusSuSE Local Security Checks
critical
84994FreeBSD : chromium -- multiple vulnerabilities (9d732078-32c7-11e5-b263-00262d5ed8ee)NessusFreeBSD Local Security Checks
critical
84992Debian DSA-3315-1 : chromium-browser - security updateNessusDebian Local Security Checks
critical
84990Debian DLA-281-1 : expat security updateNessusDebian Local Security Checks
medium
84922Google Chrome < 44.0.2403.89 Multiple Vulnerabilities (Mac OS X)NessusMacOS X Local Security Checks
high
84921Google Chrome < 44.0.2403.89 Multiple VulnerabilitiesNessusWindows
high