PHP 7.0.x < 7.0.7 Multiple Vulnerabilities

High Nessus Plugin ID 91443

Synopsis

The version of PHP running on the remote web server is affected by multiple vulnerabilities.

Description

According to its banner, the version of PHP running on the remote web server is 7.0.x prior to 7.0.7. It is, therefore, affected by multiple vulnerabilities :

- An out-of-bounds read error exists in the
_gdContributionsCalc() function within file ext/gd/libgd/gd_interpolation.c. An unauthenticated, remote attacker can exploit this to disclose sensitive information or crash the process linked against the library. (CVE-2013-7456)

- An out-of-bounds read error exists in the get_icu_value_internal() function within file ext/intl/locale/locale_methods.c due to improper handling of user-supplied input. An unauthenticated, remote attacker can exploit this to disclose sensitive information or crash the process linked against the library. (CVE-2016-5093)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PHP version 7.0.7 or later.

See Also

http://php.net/ChangeLog-7.php#7.0.7

Plugin Details

Severity: High

ID: 91443

File Name: php_7_0_7.nasl

Version: 1.3

Type: remote

Family: CGI abuses

Published: 2016/06/02

Updated: 2018/07/24

Dependencies: 48243

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 8.5

Temporal Score: 6.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2016/05/26

Vulnerability Publication Date: 2013/09/24

Reference Information

CVE: CVE-2013-7456, CVE-2016-5093