FreeBSD : pygments -- shell injection vulnerability (5f276780-b6ce-11e5-9731-5453ed2e2b49)

High Nessus Plugin ID 87830


The remote FreeBSD host is missing one or more security-related updates.


NVD reports :

The FontManager._get_nix_font_path function in formatters/ in Pygments 1.2.2 through 2.0.2 allows remote attackers to execute arbitrary commands via shell metacharacters in a font name.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 87830

File Name: freebsd_pkg_5f276780b6ce11e597315453ed2e2b49.nasl

Version: $Revision: 2.3 $

Type: local

Published: 2016/01/11

Modified: 2016/10/19

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C


Base Score: 9

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:py27-pygments, p-cpe:/a:freebsd:freebsd:py32-pygments, p-cpe:/a:freebsd:freebsd:py33-pygments, p-cpe:/a:freebsd:freebsd:py34-pygments, p-cpe:/a:freebsd:freebsd:py35-pygments, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2016/01/09

Vulnerability Publication Date: 2015/09/28

Reference Information

CVE: CVE-2015-8557