openSUSE Security Update : ppp (openSUSE-2015-827)

Medium Nessus Plugin ID 87088


The remote openSUSE host is missing a security update.


The ppp package was updated to fix one security issue.

- CVE-2015-3310: Fixed buffer overflow in radius plug-ins rc_mksid() (bnc#927841).


Update the affected ppp packages.

See Also

Plugin Details

Severity: Medium

ID: 87088

File Name: openSUSE-2015-827.nasl

Version: $Revision: 2.1 $

Type: local

Agent: unix

Published: 2015/11/30

Modified: 2015/11/30

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:ppp, p-cpe:/a:novell:opensuse:ppp-debuginfo, p-cpe:/a:novell:opensuse:ppp-debugsource, p-cpe:/a:novell:opensuse:ppp-devel, cpe:/o:novell:opensuse:13.1, cpe:/o:novell:opensuse:13.2, cpe:/o:novell:opensuse:42.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2015/11/27

Reference Information

CVE: CVE-2015-3310