CVE-2015-3310

MEDIUM

Description

Buffer overflow in the rc_mksid function in plugins/radius/util.c in Paul's PPP Package (ppp) 2.4.6 and earlier, when the PID for pppd is greater than 65535, allows remote attackers to cause a denial of service (crash) via a start accounting message to the RADIUS server.

References

http://advisories.mageia.org/MGASA-2015-0173.html

http://lists.opensuse.org/opensuse-updates/2015-11/msg00147.html

http://www.debian.org/security/2015/dsa-3228

http://www.mandriva.com/security/advisories?name=MDVSA-2015:222

http://www.securityfocus.com/bid/74163

http://www.ubuntu.com/usn/USN-2595-1

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=782450

https://security.gentoo.org/glsa/201701-50

Details

Source: MITRE

Published: 2015-04-24

Updated: 2020-02-24

Type: CWE-119

Risk Information

CVSS v2.0

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM