Scientific Linux Security Update : postgresql on SL6.x, SL7.x i386/x86_64

Medium Nessus Plugin ID 84540


The remote Scientific Linux host is missing one or more security updates.


A double-free flaw was found in the connection handling. An unauthenticated attacker could exploit this flaw to crash the PostgreSQL back end by disconnecting at approximately the same time as the authentication time out is triggered. (CVE-2015-3165)

It was discovered that PostgreSQL did not properly check the return values of certain standard library functions. If the system is in a state that would cause the standard library functions to fail, for example memory exhaustion, an authenticated user could exploit this flaw to disclose partial memory contents or cause the GSSAPI authentication to use an incorrect keytab file. (CVE-2015-3166)

It was discovered that the pgcrypto module could return different error messages when decrypting certain data with an incorrect key.
This can help an authenticated user to launch a possible cryptographic attack, although no suitable attack is currently known.

If the postgresql service is running, it will be automatically restarted after installing this update.


Update the affected packages.

See Also

Plugin Details

Severity: Medium

ID: 84540

File Name: sl_20150629_postgresql_on_SL6_x.nasl

Version: $Revision: 2.4 $

Type: local

Agent: unix

Published: 2015/07/06

Modified: 2015/10/18

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: x-cpe:/o:fermilab:scientific_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2015/06/29

Reference Information

CVE: CVE-2015-3165, CVE-2015-3166, CVE-2015-3167