SuSE 11.3 Security Update : flash-player (SAT Patch Number 10680)

critical Nessus Plugin ID 83486
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote SuSE 11 host is missing one or more security updates.

Description

The Adobe flash-player package was updated to version 11.2.202.460 to fix several security issues :

APSB15-09, CVE-2015-3044 / CVE-2015-3077 / CVE-2015-3078 / CVE-2015-3079 / CVE-2015-3080 / CVE-2015-3081 / CVE-2015-3082 / CVE-2015-3083 / CVE-2015-3084 / CVE-2015-3085 / CVE-2015-3086 / CVE-2015-3087 / CVE-2015-3088 / CVE-2015-3089 / CVE-2015-3090 / CVE-2015-3091 / CVE-2015-3092 / CVE-2015-3093.

More information can be found at the Adobe Security Bulletin APSB15-09:
https://helpx.adobe.com/security/products/flash-player/apsb15-09.html .

Solution

Apply SAT patch number 10680.

See Also

https://bugzilla.novell.com/show_bug.cgi?id=930677

http://support.novell.com/security/cve/CVE-2015-3044.html

http://support.novell.com/security/cve/CVE-2015-3077.html

http://support.novell.com/security/cve/CVE-2015-3078.html

http://support.novell.com/security/cve/CVE-2015-3079.html

http://support.novell.com/security/cve/CVE-2015-3080.html

http://support.novell.com/security/cve/CVE-2015-3081.html

http://support.novell.com/security/cve/CVE-2015-3082.html

http://support.novell.com/security/cve/CVE-2015-3083.html

http://support.novell.com/security/cve/CVE-2015-3084.html

http://support.novell.com/security/cve/CVE-2015-3085.html

http://support.novell.com/security/cve/CVE-2015-3086.html

http://support.novell.com/security/cve/CVE-2015-3087.html

http://support.novell.com/security/cve/CVE-2015-3088.html

http://support.novell.com/security/cve/CVE-2015-3089.html

http://support.novell.com/security/cve/CVE-2015-3090.html

http://support.novell.com/security/cve/CVE-2015-3091.html

http://support.novell.com/security/cve/CVE-2015-3092.html

http://support.novell.com/security/cve/CVE-2015-3093.html

Plugin Details

Severity: Critical

ID: 83486

File Name: suse_11_flash-player-150514.nasl

Version: 2.9

Type: local

Agent: unix

Published: 5/15/2015

Updated: 1/6/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: High

Score: 8.9

CVSS v2

Risk Factor: Critical

Base Score: 10

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:flash-player, p-cpe:/a:novell:suse_linux:11:flash-player-gnome, p-cpe:/a:novell:suse_linux:11:flash-player-kde4, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 5/14/2015

Exploitable With

Core Impact

Metasploit (Adobe Flash Player ShaderJob Buffer Overflow)

Reference Information

CVE: CVE-2015-3044, CVE-2015-3077, CVE-2015-3078, CVE-2015-3079, CVE-2015-3080, CVE-2015-3081, CVE-2015-3082, CVE-2015-3083, CVE-2015-3084, CVE-2015-3085, CVE-2015-3086, CVE-2015-3087, CVE-2015-3088, CVE-2015-3089, CVE-2015-3090, CVE-2015-3091, CVE-2015-3092, CVE-2015-3093