MySQL 5.5.x < 5.5.41 / 5.6.x < 5.6.22 Multiple Vulnerabilities

High Nessus Plugin ID 80886

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of MySQL installed on the remote host is version 5.5.x prior to 5.5.41 or 5.6.x prior to 5.6.22. It is, therefore, affected by vulnerabilities in the following components :

- Server : DDL
- Server : InnoDB : DDL : Foreign Key
- Server : InnoDB : DML
- Server : Optimizer
- Server : Pluggable Auth
- Server : Replication
- Server : Security : Encryption
- Server : Security : Privileges : Foreign Key

Solution

Upgrade to MySQL version 5.5.41 / 5.6.22 or later.

See Also

http://www.nessus.org/u?ae261827

http://www.nessus.org/u?6405bf15

Plugin Details

Severity: High

ID: 80886

File Name: mysql_5_6_22.nasl

Version: 1.13

Type: remote

Family: Databases

Published: 2015/01/21

Updated: 2018/11/15

Dependencies: 10719, 91823

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:mysql

Required KB Items: Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/01/20

Vulnerability Publication Date: 2015/01/20

Reference Information

CVE: CVE-2014-6568, CVE-2015-0374, CVE-2015-0381, CVE-2015-0382, CVE-2015-0385, CVE-2015-0409, CVE-2015-0411, CVE-2015-0432, CVE-2016-0594

BID: 72191, 72200, 72210, 72214, 72217, 72223, 72227, 72229