openSUSE Security Update : xorg-x11-server (openSUSE-SU-2014:1719-1)

Medium Nessus Plugin ID 80275

Synopsis

The remote openSUSE host is missing a security update.

Description

This X.Org update fixes the following security and non security issues :

- Add and update security patches. (bnc#907268, CVE-2014-8091, CVE-2014-8092, CVE-2014-8093, CVE-2014-8094, CVE-2014-8095, CVE-2014-8096, CVE-2014-8097, CVE-2014-8098, CVE-2014-8099, CVE-2014-8100, CVE-2014-8101, CVE-2014-8102, CVE-2014-8103) http://lists.x.org/archives/xorg-announce/2014-December/ 002501.html

- Fixes rendering of some icewm and xfwm themes.
(bnc#908258, bnc#856931)

Solution

Update the affected xorg-x11-server packages.

See Also

https://lists.x.org/archives/xorg-announce/2014-December/002501.html

https://bugzilla.opensuse.org/show_bug.cgi?id=856931

https://bugzilla.opensuse.org/show_bug.cgi?id=907268

https://bugzilla.opensuse.org/show_bug.cgi?id=908258

https://lists.opensuse.org/opensuse-updates/2014-12/msg00103.html

Plugin Details

Severity: Medium

ID: 80275

File Name: openSUSE-2014-815.nasl

Version: 1.3

Type: local

Agent: unix

Published: 2014/12/29

Updated: 2018/11/19

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:xorg-x11-server, p-cpe:/a:novell:opensuse:xorg-x11-server-debuginfo, p-cpe:/a:novell:opensuse:xorg-x11-server-debugsource, p-cpe:/a:novell:opensuse:xorg-x11-server-extra, p-cpe:/a:novell:opensuse:xorg-x11-server-extra-debuginfo, p-cpe:/a:novell:opensuse:xorg-x11-server-sdk, cpe:/o:novell:opensuse:12.3, cpe:/o:novell:opensuse:13.1, cpe:/o:novell:opensuse:13.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2014/12/18

Reference Information

CVE: CVE-2014-8091, CVE-2014-8092, CVE-2014-8093, CVE-2014-8094, CVE-2014-8095, CVE-2014-8096, CVE-2014-8097, CVE-2014-8098, CVE-2014-8099, CVE-2014-8100, CVE-2014-8101, CVE-2014-8102, CVE-2014-8103