phpMyAdmin 4.0.x < 4.0.10.6 / 4.1.x < 4.1.14.7 / 4.2.x < 4.2.12 Multiple Vulnerabilities (PMASA-2014-13 - PMASA-2014-16)

medium Nessus Plugin ID 79599

Synopsis

The remote web server hosts a PHP application that is affected by multiple vulnerabilities.

Description

According to its self-reported version number, the phpMyAdmin application hosted on the remote web server is 4.0.x prior to 4.0.10.6, 4.1.x prior to 4.1.14.7, or 4.2.x prior to 4.2.12. It is, therefore, affected by the following vulnerabilities :

- A cross-site scripting vulnerability in the zoom search page due to improper validation of input when handling an ENUM value before returning it to the user. A remote attacker, with a specially crafted request, could potentially execute arbitrary script code within the browser / server trust relationship. (CVE-2014-8958)

- A cross-site scripting vulnerability in the home page due to improper validation of input when handling a font size before returning it to the user. A remote attacker, with a specially crafted request, could potentially execute arbitrary script code within the browser / server trust relationship. (CVE-2014-8958)

- A cross-site scripting vulnerability in the print view page due to improper validation of input when handling an ENUM value before returning it to the user. A remote attacker, with a specially crafted request, could potentially execute arbitrary script code within the browser / server trust relationship. (CVE-2014-8958)

- A cross-site scripting vulnerability in the table browse page due to improper validation of input when handling database, table, and column names before returning them to the user. A remote attacker, with a specially crafted request, could potentially execute arbitrary script code within the browser / server trust relationship.
(CVE-2014-8958)

- A local file inclusion vulnerability in the GIS editor feature due to improperly validation of a parameter used to specify the geometry type. This could allow a remote, authenticated attacker to include arbitrary files from the host, allowing disclosure of the file contents or the execution of scripts on the host. (CVE-2014-8959)

- A cross-site scripting vulnerability in the error reporting page due to improper validation of filenames before returning them to the user. This could allow a remote attacker, with a specially crafted request, to potentially execute arbitrary script code within the browser / server trust relationship. (CVE-2014-8960)

- An information disclosure vulnerability in the error reporting feature due to improper validation of user-supplied input. This could allow a remote, authenticated attacker to determine a file's line count.
(CVE-2014-8961)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to phpMyAdmin 4.0.10.6 / 4.1.14.7 / 4.2.12 or later, or apply the patches referenced in the vendor advisory.

See Also

http://www.phpmyadmin.net/home_page/security/PMASA-2014-13.php

http://www.nessus.org/u?dfe5cc06

http://www.nessus.org/u?94943b40

http://www.nessus.org/u?866d3a60

http://www.nessus.org/u?7c5e2e33

http://www.phpmyadmin.net/home_page/security/PMASA-2014-14.php

http://www.nessus.org/u?b978eb70

http://www.nessus.org/u?ab0ccaa0

http://www.nessus.org/u?515d6830

http://www.phpmyadmin.net/home_page/security/PMASA-2014-15.php

http://www.nessus.org/u?4d2af6a3

http://www.nessus.org/u?a0200565

http://www.phpmyadmin.net/home_page/security/PMASA-2014-16.php

http://www.nessus.org/u?41a9e040

http://www.nessus.org/u?9193c577

Plugin Details

Severity: Medium

ID: 79599

File Name: phpmyadmin_pmasa_2014_16.nasl

Version: 1.6

Type: remote

Family: CGI abuses

Published: 11/27/2014

Updated: 4/11/2022

Configuration: Enable paranoid mode, Enable thorough checks

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 4.8

Vector: AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2014-8959

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Required KB Items: www/PHP, installed_sw/phpMyAdmin, Settings/ParanoidReport

Exploit Ease: No exploit is required

Patch Publication Date: 11/20/2014

Vulnerability Publication Date: 11/20/2014

Reference Information

CVE: CVE-2014-8958, CVE-2014-8959, CVE-2014-8960, CVE-2014-8961

BID: 71243, 71244, 71245, 71247

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990