CVE-2014-8959

medium

Description

Directory traversal vulnerability in libraries/gis/GIS_Factory.class.php in the GIS editor in phpMyAdmin 4.0.x before 4.0.10.6, 4.1.x before 4.1.14.7, and 4.2.x before 4.2.12 allows remote authenticated users to include and execute arbitrary local files via a crafted geometry-type parameter.

References

http://lists.opensuse.org/opensuse-updates/2014-12/msg00017.html

http://www.mandriva.com/security/advisories?name=MDVSA-2014:228

http://www.phpmyadmin.net/home_page/security/PMASA-2014-14.php

http://www.securityfocus.com/bid/71247

https://github.com/phpmyadmin/phpmyadmin/commit/80cd40b6687a6717860d345d6eb55bef2908e961

https://security.gentoo.org/glsa/201505-03

Details

Source: MITRE

Published: 2014-11-30

Updated: 2018-10-30

Type: CWE-22

Risk Information

CVSS v2

Base Score: 6.5

Vector: AV:N/AC:L/Au:S/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8

Severity: MEDIUM