PHP 5.6.0 Multiple Vulnerabilities

High Nessus Plugin ID 78556

Synopsis

The remote web server uses a version of PHP that is affected by multiple vulnerabilities

Description

According to its banner, the version of PHP installed on the remote host is a development version of 5.6.0. It is, therefore, affected by multiple vulnerabilities.

Note that Nessus has not attempted to exploit this issue but has instead relied only on application's self-reported version number.

Solution

Upgrade to the stable version of PHP 5.6.0 or later.

See Also

http://www.nessus.org/u?ab45889c

https://bugs.php.net/bug.php?id=67329

http://php.net/ChangeLog-5.php#5.6.0

Plugin Details

Severity: High

ID: 78556

File Name: php_5_6_0.nasl

Version: 1.3

Type: remote

Family: CGI abuses

Published: 2014/10/17

Updated: 2019/03/27

Dependencies: 48243

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2014-3515

CVSS v2.0

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 7.3

Temporal Score: 7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/06/03

Vulnerability Publication Date: 2014/05/22

Reference Information

CVE: CVE-2013-6712, CVE-2013-7226, CVE-2013-7327, CVE-2013-7345, CVE-2014-0185, CVE-2014-0207, CVE-2014-0236, CVE-2014-0237, CVE-2014-0238, CVE-2014-1943, CVE-2014-2270, CVE-2014-2497, CVE-2014-3478, CVE-2014-3479, CVE-2014-3480, CVE-2014-3487, CVE-2014-3515, CVE-2014-3538, CVE-2014-3587, CVE-2014-3597, CVE-2014-3981, CVE-2014-4049, CVE-2014-4670, CVE-2014-4698, CVE-2014-4721, CVE-2014-5120

BID: 67837, 64018, 65533, 69375, 68423, 68511, 68513, 68007, 65668, 66406, 67118, 68243, 90957, 67759, 67765, 65596, 69322, 66002, 66233, 68239, 68241, 68238, 68120, 68237, 68348, 69325