CVE-2013-7327

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The gdImageCrop function in ext/gd/gd.c in PHP 5.5.x before 5.5.9 does not check return values, which allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via invalid imagecrop arguments that lead to use of a NULL pointer as a return value, a different vulnerability than CVE-2013-7226.

References

http://git.php.net/?p=php-src.git;a=commit;h=8f4a5373bb71590352fd934028d6dde5bc18530b

http://www.ubuntu.com/usn/USN-2126-1

https://bugs.php.net/bug.php?id=66356

https://bugzilla.redhat.com/show_bug.cgi?id=1065108

Details

Source: MITRE

Published: 2014-02-18

Updated: 2016-09-21

Type: CWE-20

Risk Information

CVSS v2

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

Tenable Plugins

View all (7 total)

IDNameProductFamilySeverity
78556PHP 5.6.0 Multiple VulnerabilitiesNessusCGI abuses
high
77455GLSA-201408-11 : PHP: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high
73233Amazon Linux AMI : php55 (ALAS-2014-314)NessusAmazon Linux Local Security Checks
medium
73051Mandriva Linux Security Advisory : php (MDVSA-2014:059)NessusMandriva Local Security Checks
medium
72799Ubuntu 10.04 LTS / 12.04 LTS / 12.10 / 13.10 : php5 vulnerabilities (USN-2126-1)NessusUbuntu Local Security Checks
medium
8125PHP 5.5.x < 5.5.9 GD Extension Multiple Vulnerabilities Nessus Network MonitorWeb Servers
high
72511PHP 5.5.x < 5.5.9 GD Extension Multiple VulnerabilitiesNessusCGI abuses
medium