CVE-2013-6712

MEDIUM
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The scan function in ext/date/lib/parse_iso_intervals.c in PHP through 5.5.6 does not properly restrict creation of DateInterval objects, which might allow remote attackers to cause a denial of service (heap-based buffer over-read) via a crafted interval specification.

References

http://git.php.net/?p=php-src.git;a=commit;h=12fe4e90be7bfa2a763197079f68f5568a14e071

http://lists.apple.com/archives/security-announce/2015/Apr/msg00001.html

http://lists.opensuse.org/opensuse-updates/2013-12/msg00125.html

http://lists.opensuse.org/opensuse-updates/2013-12/msg00126.html

http://rhn.redhat.com/errata/RHSA-2014-1765.html

http://www.debian.org/security/2013/dsa-2816

http://www.ubuntu.com/usn/USN-2055-1

https://bugs.php.net/bug.php?id=66060

https://h20564.www2.hp.com/hpsc/doc/public/display?docId=emr_na-c04463322

https://support.apple.com/HT204659

Details

Source: MITRE

Published: 2013-11-28

Updated: 2018-10-30

Type: CWE-119

Risk Information

CVSS v2

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

Tenable Plugins

View all (22 total)

IDNameProductFamilySeverity
700510Mac OS X 10.10.x < 10.10.3 Multiple VulnerabilitiesNessus Network MonitorOperating System Detection
critical
83607SUSE SLES11 Security Update : PHP5 (SUSE-SU-2014:0064-1)NessusSuSE Local Security Checks
high
82700Mac OS X Multiple Vulnerabilities (Security Update 2015-004) (FREAK)NessusMacOS X Local Security Checks
critical
82699Mac OS X 10.10.x < 10.10.3 Multiple Vulnerabilities (FREAK)NessusMacOS X Local Security Checks
critical
80737Oracle Solaris Third-Party Patch Update : php (cve_2013_4248_input_validation)NessusSolaris Local Security Checks
high
78556PHP 5.6.0 Multiple VulnerabilitiesNessusCGI abuses
high
78336Amazon Linux AMI : php (ALAS-2014-393)NessusAmazon Linux Local Security Checks
high
78090HP System Management Homepage < 7.4 Multiple VulnerabilitiesNessusWeb Servers
high
77455GLSA-201408-11 : PHP: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high
77285PHP 5.3.x < 5.3.29 Multiple VulnerabilitiesNessusCGI abuses
high
77241FreeBSD : PHP multiple vulnerabilities (d2a892b9-2605-11e4-9da0-00a0986f28c4)NessusFreeBSD Local Security Checks
high
77047Scientific Linux Security Update : php53 and php on SL5.x, SL6.x i386/x86_64 (20140806)NessusScientific Linux Local Security Checks
high
77043Oracle Linux 5 / 6 : php / php53 (ELSA-2014-1012)NessusOracle Linux Local Security Checks
high
77032CentOS 5 / 6 : php / php53 (CESA-2014:1012)NessusCentOS Local Security Checks
high
77015RHEL 5 / 6 : php53 and php (RHSA-2014:1012)NessusRed Hat Local Security Checks
high
74876openSUSE Security Update : php5 (openSUSE-SU-2013:1963-1)NessusSuSE Local Security Checks
high
72082Mandriva Linux Security Advisory : php (MDVSA-2014:014)NessusMandriva Local Security Checks
high
71965SuSE 11.2 / 11.3 Security Update : PHP5 (SAT Patch Numbers 8683 / 8684)NessusSuSE Local Security Checks
high
71928PHP 5.5.x < 5.5.8 Multiple VulnerabilitiesNessusCGI abuses
medium
71927PHP 5.4.x < 5.4.24 Multiple VulnerabilitiesNessusCGI abuses
medium
71402Debian DSA-2816-1 : php5 - several vulnerabilitiesNessusDebian Local Security Checks
high
71394Ubuntu 10.04 LTS / 12.04 LTS / 12.10 / 13.04 / 13.10 : php5 vulnerabilities (USN-2055-1)NessusUbuntu Local Security Checks
high