MySQL 5.5.x < 5.5.40 / 5.6.x < 5.6.21 Multiple Vulnerabilities (October 2014 CPU)

High Nessus Plugin ID 78477

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of MySQL installed on the remote host is version 5.5.x prior to 5.5.40 or 5.6.x prior to 5.6.21. It is, therefore, affected by errors in the following components :

- C API SSL CERTIFICATE HANDLING
- CLIENT:SSL:yaSSL
- SERVER:DML
- SERVER:INNODB DML FOREIGN KEYS
- SERVER:OPTIMIZER
- SERVER:SSL:yaSSL

Solution

Upgrade to MySQL version 5.5.40 / 5.6.21 or later as referenced in the Oracle October 2014 Critical Patch Update advisory.

See Also

http://www.nessus.org/u?e5134a40

Plugin Details

Severity: High

ID: 78477

File Name: mysql_5_6_21.nasl

Version: 1.8

Type: remote

Family: Databases

Published: 2014/10/15

Updated: 2018/11/15

Dependencies: 91823, 10719

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:mysql

Required KB Items: Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/10/14

Vulnerability Publication Date: 2014/10/14

Reference Information

CVE: CVE-2014-6464, CVE-2014-6469, CVE-2014-6491, CVE-2014-6494, CVE-2014-6496, CVE-2014-6500, CVE-2014-6507, CVE-2014-6555, CVE-2014-6559

BID: 70444, 70446, 70451, 70469, 70478, 70487, 70497, 70530, 70550