GLSA-201408-11 : PHP: Multiple vulnerabilities
High Nessus Plugin ID 77455
SynopsisThe remote Gentoo host is missing one or more security-related patches.
DescriptionThe remote host is affected by the vulnerability described in GLSA-201408-11 (PHP: Multiple vulnerabilities)
Multiple vulnerabilities have been discovered in PHP. Please review the CVE identifiers referenced below for details.
A context-dependent attacker can cause arbitrary code execution, create a Denial of Service condition, read or write arbitrary files, impersonate other servers, hijack a web session, or have other unspecified impact.
Additionally, a local attacker could gain escalated privileges.
There is no known workaround at this time.
SolutionAll PHP 5.5 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-lang/php-5.5.16' All PHP 5.4 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-lang/php-5.4.32' All PHP 5.3 users should upgrade to the latest version. This release marks the end of life of the PHP 5.3 series. Future releases of this series are not planned. All PHP 5.3 users are encouraged to upgrade to the current stable version of PHP 5.5 or previous stable version of PHP 5.4, which are supported till at least 2016 and 2015 respectively.
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-lang/php-5.3.29'