openSUSE Security Update : cobbler (openSUSE-SU-2012:0557-1)

Medium Nessus Plugin ID 74609


The remote openSUSE host is missing a security update.


Specially crafted YAML could allow attackers to execute arbitrary code due to the use of yaml.load instead of yaml.safe_load.

Cobbler-web was prone to Cross-Site-Request-Forgery (CSRF)


Update the affected cobbler packages.

See Also

Plugin Details

Severity: Medium

ID: 74609

File Name: openSUSE-2012-247.nasl

Version: $Revision: 1.2 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2014/10/28

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:cobbler, p-cpe:/a:novell:opensuse:cobbler-web, p-cpe:/a:novell:opensuse:koan, cpe:/o:novell:opensuse:12.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2012/04/17

Reference Information

CVE: CVE-2011-4952, CVE-2011-4953, CVE-2011-4954

OSVDB: 81334, 81335, 81336