CVE-2011-4953

MEDIUM

Description

The set_mgmt_parameters function in item.py in cobbler before 2.2.2 allows context-dependent attackers to execute arbitrary code via vectors related to the use of the yaml.load function instead of the yaml.safe_load function, as demonstrated using Puppet.

References

http://lists.opensuse.org/opensuse-security-announce/2012-04/msg00019.html

https://bugs.launchpad.net/ubuntu/oneiric/+source/cobbler/+bug/858883

https://bugzilla.novell.com/show_bug.cgi?id=757062

Details

Source: MITRE

Published: 2014-10-27

Updated: 2014-10-29

Type: CWE-20

Risk Information

CVSS v2.0

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:cobbler_project:cobbler:*:*:*:*:*:*:*:* versions up to 2.2.1 (inclusive)

Tenable Plugins

View all (3 total)

IDNameProductFamilySeverity
145357openSUSE Security Update : cobbler (openSUSE-2021-46)NessusSuSE Local Security Checks
critical
74629openSUSE Security Update : cobbler (openSUSE-SU-2012:0639-1)NessusSuSE Local Security Checks
medium
74609openSUSE Security Update : cobbler (openSUSE-SU-2012:0557-1)NessusSuSE Local Security Checks
high