MySQL 5.6.x < 5.6.16 Multiple Vulnerabilities

medium Nessus Plugin ID 73573

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of MySQL installed on the remote host is version 5.6.x prior to 5.6.16. It is, therefore, affected by vulnerabilities in the following components :

- DML
- ENFED
- Federated
- MyISAM
- Optimizer
- Partition
- Privileges
- Replication
- XML

Solution

Upgrade to MySQL 5.6.16 or later.

See Also

https://dev.mysql.com/doc/relnotes/mysql/5.6/en/news-5-6-16.html

http://www.nessus.org/u?ef1fc2a6

http://www.nessus.org/u?77697fb1

Plugin Details

Severity: Medium

ID: 73573

File Name: mysql_5_6_16.nasl

Version: 1.9

Type: remote

Family: Databases

Published: 4/16/2014

Updated: 11/15/2018

Configuration: Enable paranoid mode

Supported Sensors: Frictionless Assessment Agent

Risk Information

VPR

Risk Factor: Medium

Score: 5.3

CVSS v2

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 4.8

Vector: AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:mysql

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 1/31/2014

Vulnerability Publication Date: 4/15/2014

Reference Information

CVE: CVE-2014-0384, CVE-2014-2419, CVE-2014-2432, CVE-2014-2434, CVE-2014-2438, CVE-2014-2442, CVE-2014-2444, CVE-2014-2450, CVE-2014-2451, CVE-2014-4243

BID: 66823, 66828, 66835, 66846, 66863, 66872, 66875, 66880, 66885, 68611