MySQL 5.6.x < 5.6.15 Multiple Vulnerabilities

medium Nessus Plugin ID 71976
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote database server may be affected by multiple vulnerabilities.

Description

The version of MySQL installed on the remote host is 5.6.x older than 5.6.15. As such, it is reportedly affected by vulnerabilities in the following components :

- Error Handling
- GIS
- InnoDB
- Privileges
- Optimizer
- Replication

Solution

Upgrade to MySQL 5.6.15 or later.

See Also

https://dev.mysql.com/doc/relnotes/mysql/5.6/en/news-5-6-15.html

http://www.nessus.org/u?1ac50e41

Plugin Details

Severity: Medium

ID: 71976

File Name: mysql_5_6_15.nasl

Version: 1.7

Type: remote

Family: Databases

Published: 1/15/2014

Updated: 11/15/2018

Dependencies: mysql_version.nasl, mysql_login.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: AV:N/AC:L/Au:S/C:N/I:N/A:C

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:mysql

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 12/3/2013

Vulnerability Publication Date: 1/14/2014

Reference Information

CVE: CVE-2013-5860, CVE-2013-5881, CVE-2013-5908, CVE-2014-0401, CVE-2014-0412, CVE-2014-0420, CVE-2014-0431, CVE-2014-0437

BID: 64849, 64864, 64880, 64885, 64888, 64896, 64897, 64898