PostgreSQL 8.4 < 8.4.17 / 9.0 < 9.0.13 / 9.1 < 9.1.9 / 9.2 < 9.2.4 Predictable Random Number Generator

High Nessus Plugin ID 65856

Synopsis

The remote database server is affected by an issue in the random number generator.

Description

The version of PostgreSQL installed on the remote host is 8.4.x prior to 8.4.17, 9.0.x prior to 9.0.13, 9.1.x prior to 9.1.9, or 9.2.x prior to 9.2.4. As such, it is potentially affected by an issue where random numbers generated by contrib/pgcrypto functions may be easy for another database user to guess.

Solution

Upgrade to PostgreSQL 8.4.17 / 9.0.13 / 9.1.9 / 9.2.4 or later.

See Also

https://www.postgresql.org/about/news/1456/

https://www.postgresql.org/docs/8.4/release-8-4-17.html

https://www.postgresql.org/docs/9.0/release-9-0-13.html

http://www.postgresql.org/docs/9.1/static/release-9-1-9.html

http://www.postgresql.org/docs/9.2/static/release-9-2-4.html

https://www.vmware.com/security/advisories/VMSA-2013-0005.html

Plugin Details

Severity: High

ID: 65856

File Name: postgresql_cve20131900.nasl

Version: 1.14

Type: remote

Family: Databases

Published: 2013/04/08

Updated: 2018/11/15

Dependencies: 63346

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 8.5

Temporal Score: 6.3

Vector: CVSS2#AV:N/AC:M/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:postgresql:postgresql

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/04/04

Vulnerability Publication Date: 2013/03/27

Reference Information

CVE: CVE-2013-1900

BID: 58879

VMSA: 2013-0005