CVE-2013-1900

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

PostgreSQL 9.2.x before 9.2.4, 9.1.x before 9.1.9, 9.0.x before 9.0.13, and 8.4.x before 8.4.17, when using OpenSSL, generates insufficiently random numbers, which might allow remote authenticated users to have an unspecified impact via vectors related to the "contrib/pgcrypto functions."

References

http://lists.apple.com/archives/security-announce/2013/Sep/msg00002.html

http://lists.apple.com/archives/security-announce/2013/Sep/msg00004.html

http://lists.fedoraproject.org/pipermail/package-announce/2013-April/101519.html

http://lists.fedoraproject.org/pipermail/package-announce/2013-April/102806.html

http://lists.opensuse.org/opensuse-security-announce/2013-04/msg00007.html

http://lists.opensuse.org/opensuse-security-announce/2013-04/msg00008.html

http://lists.opensuse.org/opensuse-security-announce/2013-04/msg00011.html

http://lists.opensuse.org/opensuse-security-announce/2013-04/msg00012.html

http://rhn.redhat.com/errata/RHSA-2013-1475.html

http://support.apple.com/kb/HT5880

http://support.apple.com/kb/HT5892

http://www.debian.org/security/2013/dsa-2657

http://www.debian.org/security/2013/dsa-2658

http://www.mandriva.com/security/advisories?name=MDVSA-2013:142

http://www.oracle.com/technetwork/security-advisory/cpuoct2017-3236626.html

http://www.postgresql.org/about/news/1456/

http://www.postgresql.org/docs/current/static/release-8-4-17.html

http://www.postgresql.org/docs/current/static/release-9-0-13.html

http://www.postgresql.org/docs/current/static/release-9-1-9.html

http://www.postgresql.org/docs/current/static/release-9-2-4.html

http://www.ubuntu.com/usn/USN-1789-1

Details

Source: MITRE

Published: 2013-04-04

Updated: 2017-10-20

Type: CWE-189

Risk Information

CVSS v2

Base Score: 8.5

Vector: AV:N/AC:M/Au:S/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 6.8

Severity: HIGH

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:postgresql:postgresql:9.2:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.2.1:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.2.2:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.2.3:*:*:*:*:*:*:*

Configuration 2

OR

cpe:2.3:a:postgresql:postgresql:9.1:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.1.1:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.1.2:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.1.3:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.1.4:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.1.5:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.1.6:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.1.7:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.1.8:*:*:*:*:*:*:*

Configuration 3

OR

cpe:2.3:a:postgresql:postgresql:9.0:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.0.1:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.0.2:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.0.3:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.0.4:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.0.5:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.0.6:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.0.7:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.0.8:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.0.9:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.0.10:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.0.11:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.0.12:*:*:*:*:*:*:*

Configuration 4

OR

cpe:2.3:a:postgresql:postgresql:8.4:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.4.1:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.4.2:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.4.3:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.4.4:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.4.5:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.4.6:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.4.7:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.4.8:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.4.9:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.4.10:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.4.11:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.4.12:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.4.13:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.4.14:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.4.15:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.4.16:*:*:*:*:*:*:*

Configuration 5

OR

cpe:2.3:o:canonical:ubuntu_linux:8.04:-:lts:*:*:*:*:*

cpe:2.3:o:canonical:ubuntu_linux:10.04:-:lts:*:*:*:*:*

cpe:2.3:o:canonical:ubuntu_linux:11.10:*:*:*:*:*:*:*

cpe:2.3:o:canonical:ubuntu_linux:12.04:-:lts:*:*:*:*:*

cpe:2.3:o:canonical:ubuntu_linux:12.10:*:*:*:*:*:*:*

Tenable Plugins

View all (25 total)

IDNameProductFamilySeverity
77459GLSA-201408-15 : PostgreSQL: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high
74963openSUSE Security Update : postgresql91 (openSUSE-SU-2013:0627-1)NessusSuSE Local Security Checks
high
74962openSUSE Security Update : postgresql92 (openSUSE-SU-2013:0628-1)NessusSuSE Local Security Checks
high
70906Amazon Linux AMI : postgresql8 (ALAS-2013-244)NessusAmazon Linux Local Security Checks
high
70705Scientific Linux Security Update : postgresql and postgresql84 on SL5.x, SL6.x i386/x86_64 (20131029)NessusScientific Linux Local Security Checks
high
70696RHEL 5 / 6 : postgresql and postgresql84 (RHSA-2013:1475)NessusRed Hat Local Security Checks
high
70692Oracle Linux 5 / 6 : postgresql / postgresql84 (ELSA-2013-1475)NessusOracle Linux Local Security Checks
high
70687CentOS 5 / 6 : postgresql / postgresql84 (CESA-2013:1475)NessusCentOS Local Security Checks
high
69932Mac OS X : OS X Server < 2.2.2 Multiple VulnerabilitiesNessusMacOS X Local Security Checks
high
8008Mac OS X 10.8 < 10.8.5 Multiple Vulnerabilities (Security Update 2013-004)Nessus Network MonitorWeb Clients
critical
69878Mac OS X Multiple Vulnerabilities (Security Update 2013-004)NessusMacOS X Local Security Checks
critical
69877Mac OS X 10.8.x < 10.8.5 Multiple VulnerabilitiesNessusMacOS X Local Security Checks
critical
69737Amazon Linux AMI : postgresql9 (ALAS-2013-178)NessusAmazon Linux Local Security Checks
high
66168Fedora 19 : postgresql-9.2.4-1.fc19 (2013-6148)NessusFedora Local Security Checks
high
66154Mandriva Linux Security Advisory : postgresql (MDVSA-2013:142)NessusMandriva Local Security Checks
high
65856PostgreSQL 8.4 < 8.4.17 / 9.0 < 9.0.13 / 9.1 < 9.1.9 / 9.2 < 9.2.4 Predictable Random Number GeneratorNessusDatabases
high
65841FreeBSD : PostgreSQL -- anonymous remote access data corruption vulnerability (3f332f16-9b6b-11e2-8fe9-08002798f6ff)NessusFreeBSD Local Security Checks
high
65829SuSE 11.2 Security Update : PostgreSQL (SAT Patch Number 7585)NessusSuSE Local Security Checks
high
65828Fedora 17 : postgresql-9.1.9-1.fc17 (2013-5000)NessusFedora Local Security Checks
high
65827Fedora 18 : postgresql-9.2.4-1.fc18 (2013-4951)NessusFedora Local Security Checks
high
6746PostgreSQL < 8.4.17 Multiple VulnerabilitiesNessus Network MonitorDatabase
medium
6745PostgreSQL < 9.0.13 Multiple VulnerabilitiesNessus Network MonitorDatabase
medium
6744PostgreSQL < 9.1.9 / 9.2.4 Multiple VulnerabilitiesNessus Network MonitorDatabase
medium
65818Ubuntu 8.04 LTS / 10.04 LTS / 11.10 / 12.04 LTS / 12.10 : postgresql-8.3, postgresql-8.4, postgresql-9.1 vulnerabilities (USN-1789-1)NessusUbuntu Local Security Checks
high
65812Debian DSA-2657-1 : postgresql-8.4 - guessable random numbersNessusDebian Local Security Checks
high