MySQL 5.1 < 5.1.62 Multiple Vulnerabilities

medium Nessus Plugin ID 58802


The remote database server is affected by multiple vulnerabilities.


The version of MySQL 5.1 installed on the remote host is earlier than 5.1.62. It is, therefore, affected by the following vulnerabilities :

- An error exists related to the included yaSSL component that could allow arbitrary code execution.

- Errors exist related to 'Server Optimizer', 'Server DML', 'Partition' and, in combination with InnoDB, 'HANDLER READ NEXT' that could allow denial of service attacks. (CVE-2012-1688, CVE-2012-1690, CVE-2012-1703, CVE-2012-2102)


Upgrade to MySQL version 5.1.62 or later.

See Also

Plugin Details

Severity: Medium

ID: 58802

File Name: mysql_5_1_62.nasl

Version: 1.11

Type: remote

Family: Databases

Published: 4/19/2012

Updated: 11/15/2018

Configuration: Enable paranoid mode

Supported Sensors: Frictionless Assessment Agent

Risk Information


Risk Factor: Medium

Score: 5.9


Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: cpe:/a:mysql:mysql

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 3/21/2012

Vulnerability Publication Date: 4/17/2012

Reference Information

CVE: CVE-2012-0882, CVE-2012-1688, CVE-2012-1690, CVE-2012-1703, CVE-2012-2102

BID: 51925, 52931, 53058, 53067, 53074