FreeBSD : databases/postgresql*-client -- multiple vulnerabilities (174b8864-6237-11e1-be18-14dae938ec40)

Medium Nessus Plugin ID 58162


The remote FreeBSD host is missing one or more security-related updates.


The PostgreSQL Global Development Group reports :

These vulnerabilities could allow users to define triggers that execute functions on which the user does not have EXECUTE permission, allow SSL certificate spoofing and allow line breaks in object names to be exploited to execute code when loading a pg_dump file.


Update the affected packages.

See Also

Plugin Details

Severity: Medium

ID: 58162

File Name: freebsd_pkg_174b8864623711e1be1814dae938ec40.nasl

Version: $Revision: 1.7 $

Type: local

Published: 2012/02/29

Modified: 2013/06/21

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:postgresql-client, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2012/02/28

Vulnerability Publication Date: 2012/02/27

Reference Information

CVE: CVE-2012-0866, CVE-2012-0867, CVE-2012-0868